Production backlog

Minor incident Production UV printing Laser engraving Sublimation Shipping
2026-08-17 19:15 UTC · 14 hours, 48 minutes

Updates

Resolved

Production is back on schedule

August 18, 2026 · 10:03 UTC
Update

Production is back on schedule

August 18, 2026 · 09:59 UTC
Issue

Part of the orders of today (Monday 17th) is delayed due to high volume and shortage in staff planning. We expect to be back on schedule tomorrow (Tuesday 18th).

August 17, 2026 · 19:15 UTC

← Back