Printeers Status
Subscribe
to updates
Part of sublimation production delayed 1 day
Minor incident
Production
Sublimation
2026-07-30 17:39 UTC
· 14 hours, 31 minutes
Updates
Resolved
Sublimation production is back on track.
July 31, 2026 · 08:10 UTC
Issue
10% of sublimation production delayed until tomorrow.
July 30, 2026 · 17:39 UTC
← Back