Part of sublimation production delayed 1 day

Minor incident Production Sublimation
2026-07-21 08:01 UTC · 1 hour, 34 minutes

Updates

Resolved

Sublimation production of large items is back on track.

July 21, 2026 · 09:36 UTC
Issue

Orders for larger phones sublimation items can be delayed one day due to high order volume:

  • T11960000 Samsung Galaxy S26 Ultra Tough case (fully printed, black insert)
  • Q10300000 Samsung Galaxy S26 Ultra MagSafe Tough case (fully printed, black insert)
  • T11540000 Apple iPhone 16 Pro Max Tough case (fully printed, black insert)
  • T11400000 Samsung Galaxy S22 Ultra Tough case (fully printed, black insert)
  • T11810000 Apple iPhone 17 Pro Max Tough case (fully printed, black insert)
  • Q10210000 Apple iPhone 17 Pro Max MagSafe Tough case (fully printed, black insert)
  • T11570000 Samsung Galaxy S25 Ultra Tough case (fully printed, black insert)
  • T11340000 Apple iPhone 14 Pro Max Tough case (fully printed, black insert)
July 21, 2026 · 08:01 UTC

← Back